Page 1 of 1

Weird AI behavior at start

Posted: Fri Apr 08, 2016 6:02 am
by dwbmb
Summary of the bug :

Look at weird AI behavior, at least one of them is always going reverse on start.

Which version of Grip were you using :
1.0.9

When does this happen :
See Summary

On which track did it happen :
All of them

On which speed did that happen (if related to physics) :
0 km/h

How often does this happen :
Always

How to replicate the steps (if reproducible) :
See Summary

More details :
If you do not accelerate after start, the AI ahead of you will reverse to you and then he begins to race.

Your specs :
Core i7, GTX570 Ti, 16GB RAM

Any screenshot, or link to a video showing the bug :
YouTube: https://youtu.be/NS5QfeITBgk

Re: No gas at start

Posted: Sun Apr 10, 2016 3:53 pm
by Chris_CE
dwbmb wrote:Look at weird AI behavior, at least one of them is always going reverse on start.

Can you elaborate? I've never seen this happen

Re: No gas at start

Posted: Mon Apr 11, 2016 2:49 am
by dwbmb
If you do not accelerate after start, the AI ahead of you will reverse to you and then he begins to race. That is all I can see.

Re: No gas at start

Posted: Mon Apr 11, 2016 4:05 am
by omegalucas
It has been happening to me too. Even when I accelerate, some of the AI stand still or go on reverse, which makes it chaotic because most cars get stuck there.

It's a behavior I never saw before 1.0.9.

Re: No gas at start

Posted: Mon Apr 11, 2016 6:31 am
by codemonkey
I can't see how this can happen unless you're blocking the path of the AI behind you, certainly nothing in front of you should reverse unless something else is blocking them. I'm working on overtaking behaviour now coincidentally, so I'll ensure nothing dumb happens there before I'm finished.

The no-gas thing is almost certainly an initialisation issue with UE, and I'm not sure there's very much we can do about that.

Re: No gas at start

Posted: Tue Apr 12, 2016 9:06 pm
by TheOnLY
I caught the AI reversing thing on video twice. They reverse even when they start in the first row. But it is only Dreadnoughts doing that.
https://youtu.be/QALWUpF8GDM
Maybe they are staying in the same spot for too long because of the wheels spinning,so they reverse because they think they are stuck

Re: Weird AI behavior at start

Posted: Wed Apr 13, 2016 6:16 am
by dwbmb
Chenged topic name and adding one more video:

https://youtu.be/pvUu9Au5E9g