[LOGGED] Arrow keys stop responding

Post any bugs here that you experience with running GRIP.

Please USE OUR BUG REPORTING TEMPLATE, or your thread might be reformatted or removed.
User avatar
savePinball
Early Supporter 2
Early Supporter 2
Posts: 9
Joined: Fri Jul 10, 2015 4:05 am
Location: New Zealand

[LOGGED] Arrow keys stop responding

Postby savePinball » Tue Dec 01, 2015 8:15 pm

Summary of the bug :

During race Arrow keys stop responding. WASD keys still work.

When does this happen :

While Racing.

On which track did it happen :

Have only seen it happen on Industrial but I think it will effect all Tracks and the Arena Mode.

On which speed did that happen:

N/A

How often does this happen :

Occasionally.

How to replicate the steps :

This is what I've been trying to work out for a while but I remember trying to change targets for the rockets and firing and then the arrow keys not responding. Will edit if I figure out why and how to replicate it.

More details :
Since no one else has reported this maybe just me :?

Your specs :
Win 7
GTX 680
i7 2700K
16 GB DDR3
750w PSU

Any screenshot, or link to a video showing the bug:
I have no space on my Hard drive so would be hard to record. Hopefully I find out how to replicate it then I can record it.
One day I will get the boost on the start of a multiplayer race...
GODDAMN INTERNET YOU LET ME DOWN!

User avatar
SyncrQ
Early Supporter 6
Early Supporter 6
Posts: 19
Joined: Tue Sep 01, 2015 5:34 pm
Location: Germany

Re: Arrow keys stop responding

Postby SyncrQ » Wed Dec 02, 2015 4:38 pm

Summary of the bug :
During race Arrow keys stop responding. WASD keys still work.


When does this happen :
while racing


On which track did it happen : at all tracks


How to replicate the steps (if reproducible) : while racing, you just have to press "TAB" on the left side. the neighbor of "Q".

More details : You will get a frame arround the screen. when you press a mouse key, the frame is gone and you can use the arrow keys again.
Maybe its not a bug, but a feature :)


Your specs :
•Win 7 64bit
•GTX 570
•i5 3570k
•8 gb DDR3 1600 MHz
•550W

Any screenshot, or link to a video showing the bug :
2015-12-02_00001.jpg
2015-12-02_00001.jpg (231.58 KiB) Viewed 3944 times

User avatar
potterman28wxcv
Early Supporter 6
Early Supporter 6
Posts: 1285
Joined: Wed Jul 01, 2015 12:20 pm
Location: Grenoble - France
Contact:

Re: Arrow keys stop responding

Postby potterman28wxcv » Wed Dec 02, 2015 5:48 pm

Logged, thanks for the reports :)
Because I'm even more boring than Broscar -> Rules of the GRIP forum
Check out the sign-ups for the Rollcage Neo-mode Tournament 2017, starting 15th April !

And with a rusty wrench
God created the french

Admin of the Image

User avatar
savePinball
Early Supporter 2
Early Supporter 2
Posts: 9
Joined: Fri Jul 10, 2015 4:05 am
Location: New Zealand

Re: Arrow keys stop responding

Postby savePinball » Wed Dec 02, 2015 6:46 pm

SyncrQ wrote:Summary of the bug :
During race Arrow keys stop responding. WASD keys still work.


When does this happen :
while racing


On which track did it happen : at all tracks


How to replicate the steps (if reproducible) : while racing, you just have to press "TAB" on the left side. the neighbor of "Q".

More details : You will get a frame arround the screen. when you press a mouse key, the frame is gone and you can use the arrow keys again.
Maybe its not a bug, but a feature :)


Your specs :
•Win 7 64bit
•GTX 570
•i5 3570k
•8 gb DDR3 1600 MHz
•550W

Any screenshot, or link to a video showing the bug :
2015-12-02_00001.jpg


Oh that's what it was. Thanks SyncrQ! :D
I now remember pushing the tab key. :roll:
That's alright potterman28wxcv!
One day I will get the boost on the start of a multiplayer race...
GODDAMN INTERNET YOU LET ME DOWN!

User avatar
Demi
Early Supporter 6
Early Supporter 6
Posts: 22
Joined: Thu Jul 09, 2015 5:57 pm
Location: Germany

Re: [LOGGED] Arrow keys stop responding

Postby Demi » Mon Feb 08, 2016 2:32 pm

This bug is back.
In the List it is listed as fixed in 1.0.5 but it is present for me in 1.0.7.

User avatar
Chris_CE
Grip Developer
Grip Developer
Posts: 2175
Joined: Tue Jun 30, 2015 4:44 pm
Contact:

Re: [LOGGED] Arrow keys stop responding

Postby Chris_CE » Thu Feb 11, 2016 10:47 am

were you pressing any keys that aren't listed in the control mappings prior to this happening?
Game Director
GRIP

User avatar
Demi
Early Supporter 6
Early Supporter 6
Posts: 22
Joined: Thu Jul 09, 2015 5:57 pm
Location: Germany

Re: [LOGGED] Arrow keys stop responding

Postby Demi » Thu Feb 11, 2016 12:39 pm

Only the tab key, as described by SyncrQ.

I start a race, wait for it to start and press the tab key. Then a dashed white line appears on the borders of the screen and the arrow keys stop responding. When i click a mouse button the lines disappear and the keys work again.

User avatar
Chris_CE
Grip Developer
Grip Developer
Posts: 2175
Joined: Tue Jun 30, 2015 4:44 pm
Contact:

Re: [LOGGED] Arrow keys stop responding

Postby Chris_CE » Thu Feb 11, 2016 12:55 pm

Ok so it's pretty minor. Thanks for the report!
Game Director
GRIP


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest

cron