No mouse cursor at 200%+ zoom in Windows 7

Post any bugs here that you experience with running GRIP.

Please USE OUR BUG REPORTING TEMPLATE, or your thread might be reformatted or removed.
MT_
Posts: 9
Joined: Sun Mar 18, 2018 8:35 pm

No mouse cursor at 200%+ zoom in Windows 7

Postby MT_ » Sun Mar 18, 2018 9:19 pm

Mouse cursor is invisible at zoom of 200% and higher in Windows 7 Home Premium 64 bit. This makes it almost impossible to navigate though the game menu and therefore makes the game itself unplayable.

Please note the issue is specific to Windows 7 and apparently does not reproduce under Windows 10 on the same PC.

This video (3 MB) demonstrates the issue in action:

Spoiler: show


My hardware:
  • 4K monitor: Dell P2415Q connected via DisplayPort.
  • Graphics card: GeForce GTX 650 Ti BOOST (2 GB) (Gigabyte GV-N65TBOC-2GD).
  • Mainboard: Gigabyte GA-Z68X-UD4-B3.
  • CPU: Intel Core i7-3770T (4 cores).
  • RAM: 16 GB (4×4 GB, Hynix).
  • Power: Corsair AX850 (850 W, Seasonic-based).
  • OS: Windows 7 Home Premium SP1 (build 7601) (64 bit) at 200% OS-level zoom.
Last edited by MT_ on Tue May 01, 2018 9:04 pm, edited 6 times in total.

User avatar
Broscar
Early Supporter 6
Early Supporter 6
Posts: 648
Joined: Wed Jul 01, 2015 2:35 pm
Location: ur mom #shrekt
Contact:

Re: [BUG] Mouse cursor is invisible at 200%+ zoom in Windows 7

Postby Broscar » Fri Mar 30, 2018 12:37 pm

Isn't this simply due to Windows 7 having mediocre high dpi support?

Also, my apologies for the late post approval. Everyone is mad busy with working on the game for the final stretch or attending GDC.

MT_
Posts: 9
Joined: Sun Mar 18, 2018 8:35 pm

Re: [BUG] Mouse cursor is invisible at 200%+ zoom in Windows 7

Postby MT_ » Sat Mar 31, 2018 12:59 pm

Windows 7 has basically the same HiDPI support as Windows 10. Please note that Windows 7 has almost the same market share as Windows 10.

Windows 10 simply adds Per-monitor DPI awareness, Mixed-mode (per-window) DPI awareness, scaling GDI-rendered windows and (for end user) ability to override application’s DPI awareness in arbitrary direction (e.g. to disable DPI awareness). These have nothing to do with HiDPI support in general and visibility of mouse cursor in particular.

Fwiw, Windows 10 also have mouse cursors designed specifically for zoom levels of 200% and higher, while Windows 7 has cursors for 150% as maximum by default and upscales them if a higher zoom is used. This may (or not) be the key to finding the issue reason, though I personally simply borrowed cursors for 200% from Windows 10, so the issue is certainly NOT with that cursor files are missing.

For me, GRIP is the first game EVER that has the issue with invisible mouse cursor and is uplayable under Windows 7 due to this.

Thanks.

MT_
Posts: 9
Joined: Sun Mar 18, 2018 8:35 pm

No cursor at 200% — video

Postby MT_ » Sat Mar 31, 2018 2:15 pm

I recorded a small video showing the bug in action and added it to the starting message.

User avatar
Broscar
Early Supporter 6
Early Supporter 6
Posts: 648
Joined: Wed Jul 01, 2015 2:35 pm
Location: ur mom #shrekt
Contact:

Re: Mouse cursor is invisible at 200%+ zoom in Windows 7

Postby Broscar » Mon Apr 02, 2018 6:51 pm

Thanks for the bug reports, MT_.
I'll put this and the other one you made on the big list of 'HEY FIX THIS'. To be completely honest this specific one might be a post-release fix thing if we can't diagnose it in time though.

MT_
Posts: 9
Joined: Sun Mar 18, 2018 8:35 pm

Re: Mouse cursor is invisible at 200%+ zoom in Windows 7

Postby MT_ » Wed Apr 04, 2018 10:30 pm

Hopefully you’ll be able to prioritize based on importance and complexity.

Unavailability of the game for 50% of 4K-monitor owners (this issue) is probably quite critical.

Adding a proper DPI-awareness declaration (the second issue) is not critical, but important in long term and trivial as long as building process is under the GRIP developers’ control.

Thanks.

MT_
Posts: 9
Joined: Sun Mar 18, 2018 8:35 pm

Re: Mouse cursor is invisible at 200%+ zoom in Windows 7

Postby MT_ » Fri Apr 06, 2018 1:32 pm

Another video by another 4K-monitor owner suffering from the bug:

https://www.youtube.com/watch?v=ZYKFm0I6OHE

Looks like the `youtube` pseudotags don’t work on this forum, tried different ways to use them:

[youtube]https://www.youtube.com/watch?v=ZYKFm0I6OHE[/youtube]
[youtube]ZYKFm0I6OHE[/youtube]
[youtube]<iframe width="1148" height="646" src="https://gaming.youtube.com/embed/ZYKFm0I6OHE" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>[/youtube]


Return to “Bug Reports”

Who is online

Users browsing this forum: Bing [Bot] and 0 guests

cron